Beta 0.4 now compatible w/ Patch 1.3

DoW2 Skirmish mod

Beta 0.4 now compatible w/ Patch 1.3

Postby Clonesa » Tue May 12, 2009 5:13 pm

So the new Patch 1.3 today broke the mod. I'll be working quickly to fix it, however this seems like a worst case scenario. Approximately 81% of the attribute files have changed. I have ported the data files already, but the largest work is still ahead. The mod will crash if you start a skirmish match. This will not permanently harm your game in any way. I have not tested the campaign.
[edit] decided to make additional changes and release 0.4, 0.4 is 1.3 compatible. 0.45 will follow closely after official Patch 1.3.2 release.
Clonesa
Owner
 
Posts: 36
Joined: Wed Mar 18, 2009 12:26 am
WordPress Blog: Visit User's Blog

Re: Beta 0.3 NOT compatible w/ Patch 1.3

Postby Clonesa » Tue May 12, 2009 7:54 pm

I would say im about 30% through getting the mod to full compatibility.
I may have to temporarily revert some campaign wargear changes to get a working patch out faster. For patch 0.35 the bonus package wargear will not drop (people with the actual bonus packages are unaffected). This will be fixed in 0.4, sorry to the people who used the mod for wargear in campaign.
Clonesa
Owner
 
Posts: 36
Joined: Wed Mar 18, 2009 12:26 am
WordPress Blog: Visit User's Blog

Re: Beta 0.3 NOT compatible w/ Patch 1.3

Postby Gorb » Wed May 13, 2009 3:45 am

I did say you should wait til after the patch before releasing your next version. :)

Ah well, you did it anyway. You must be a sucker for extra work or something.
Gorb
 
Posts: 5
Joined: Thu Mar 19, 2009 6:54 pm

Re: Beta 0.3 NOT compatible w/ Patch 1.3

Postby Clonesa » Thu May 14, 2009 2:15 pm

Well, I was hoping it wouldn't totally break it :( So, I'm rewriting the mod. Hit a debugging brick wall essentially. I could've gone through and deleted files until I found which ones were causing the crash, but many of the files are linked and that still wouldn't update them with the decorators and such. Its probably best this way as there was some sloppy code in there.
Now they're going to release 1.3.2 T.T
Clonesa
Owner
 
Posts: 36
Joined: Wed Mar 18, 2009 12:26 am
WordPress Blog: Visit User's Blog

Re: Beta 0.4 now compatible w/ Patch 1.3

Postby Clonesa » Sat May 16, 2009 8:59 pm

I decided to make some additional changes I wanted to do and redo a lot of the code. Sorry for the wait. I skipped 0.35 and am releasing 0.4 now, which is fully 1.3 compatible and fixes the UCS conflict problem. Bunch of new changes too, see readme post.
Clonesa
Owner
 
Posts: 36
Joined: Wed Mar 18, 2009 12:26 am
WordPress Blog: Visit User's Blog


Return to Worlds of Strife

Who is online

Users browsing this forum: No registered users and 1 guest

cron